[Tinyos-devel] current draw in deep sleep for telosb

Vlado Handziski handzisk at tkn.tu-berlin.de
Sat Jun 30 01:24:59 PDT 2007


I suspect a HW problem on your testing node. Have you tried with another
one? The content of MotePlatformC has been stable for a long time and Null
consumes ~ 7-8uA on a sensor populated node without any modifications to the
code. In general, when not used, the pins on the msp430 are put in input to
reduce the leakage currents.

Vlado

On 6/30/07, Razvan Musaloiu-E. <razvanm at cs.jhu.edu> wrote:
>
> Hi!
>
> I'm running the latest CVS and today I noticed that the Null application
> on
> telosb draws an unusually high (and variable) amount current (around
> 0.5-0.8mA). The problem seems to be in in Init.init function from
> MotePlatformC.nc from tos/platforms/telosb/. At the end of it the
> TOSH_FLASH_M25P_DP function the clock pin is put on input. By making it
> output on zero the current stabilized to the normal low values (7-8uA). I
> attached the patch with the changes. It can be aplied by running the
> following commands:
>         cd $TOSROOT
>         patch -p0 < telosb-current.diff
>
> Can somebody confirm the problem and test this solution?
>
> Thank you!
> Razvan ME
> _______________________________________________
> Tinyos-devel mailing list
> Tinyos-devel at Millennium.Berkeley.EDU
> https://mail.millennium.berkeley.edu/cgi-bin/mailman/listinfo/tinyos-devel
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.millennium.berkeley.edu/pipermail/tinyos-devel/attachments/20070630/94e22c87/attachment.html


More information about the Tinyos-devel mailing list