[Tinyos-help] radio verification still not working

Kristin Wright kwright at cs.berkeley.edu
Fri Jan 23 13:03:56 PST 2004


What happened if you didn't do install.0? Are you certain that you're using
COM1 (probably since it looks as if you have already tested one of your
mica2s)?

 

The ID shouldn't because since MicaHWVerify broadcasts the packets sent
across the network (as opposed to those sent across the serial line). 

 

Try this for your PFLAGS (for convenience, you can put it in your Makelocal
file since you'll probably now want to change the definition):

PFLAGS=-DCC1K_DEF_FREQ=914077000

(I believe CC1K_MANUAL_FREQ will probably still work, but it's deprecated.)

 

This contradicts the documentation a bit, but you might try moving through
the tutorial toward lesson 4 where you use the radio in a tutorial
application. The MicaHWVerify app can sometimes difficult to configure
because you have to get all your ducks in a row at one time (that is, there
are many things that you have to get right at once). Sometimes it's easier
to assume the hardware works (which it usually does) and move through the
tutorial where you only have to get one duck in a row at one time.

 

-kw

  _____  

From: tinyos-help-bounces at Millennium.Berkeley.EDU
[mailto:tinyos-help-bounces at Millennium.Berkeley.EDU] On Behalf Of Wang Chong
Sent: Thursday, January 22, 2004 4:28 PM
To: tinyos-help at Millennium.Berkeley.EDU
Subject: [Tinyos-help] radio verification still not working

 

hi, I was stopped by the last step of radio verification. I compiled the
TOSBase, and install it on the mote(MICA2),

change directory to MicaHWVerify, and run the java hardware_check. of
courseI put a tested blinking MICA2 mote nearby. What I get is:

"Hardware check started

  Serial at COM1:57600: resynchronising

  Node transmission failure"

 

What's wrong?

 

Anybody help me? Thank you very much!

 

P.S. when I install the MicaHWVerify, I had to use make mica2 install.0, in
order to make it work. Could this be a problem? the default Group ID is
0x7d, though. The frequency I used is 914_077_MHZ in the command "
PFLAGS=...."

 

 

I'm using Mica2 900MHZ, tinyOS1.1.0, Dell Latitude Notebook.

 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://Mail.Millennium.Berkeley.EDU/pipermail/tinyos-help/attachments/20040123/e7e0d0b4/attachment.htm


More information about the Tinyos-help mailing list