[Tinyos-help] CTP: Motes don't send packets although routes are found

Maissa Ben Jamaa maisa.benjamaa at gmail.com
Tue Apr 13 16:24:08 PDT 2010


Hello Omprakash,
Glad to hear that you are interested in our work, this motivates us more.
Thank you.
I already tested CTP+4bit and it worked fine, I think that I have a bug
somewhere in my code.

By the way, I wanted to post a question to tinyos-help asking about some
formula in 4bit especially this one:
newEst = (255 * ne->rcvcnt) / totalPkt;
Can you please tell me why you multiply the numerator with 255 and not with
other value such as 100.
Thanks again,

Best regards,
Maissa Ben Jamaa


2010/4/13 Omprakash Gnawali <gnawali at cs.stanford.edu>

> On Mon, Apr 5, 2010 at 11:52 PM, Maisa Ben Jamaa
> <maisa.benjamaa at gmail.com> wrote:
> > Hello,
> > Actually, I have changed the code of CTP in order to implement this
> > estimator :http://www.springerlink.com/content/57642v20401h1336/
> > I tried to run the new CTP with testNetwork app but I get bad behavior
> > (motes do not send neither packet nor beacons), so may be I have wrong
> > instructions in my implementation. I am trying to fix this.
>
> You should first test without changing any code. I am interested in
> hearing the results of your experiment.
>
> - om_p
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20100414/be28ad9b/attachment.htm 


More information about the Tinyos-help mailing list