[Tinyos-help] troubles installing TinyOs on ubuntu karmic

MrOrange themrorange at gmail.com
Mon Apr 19 08:09:01 PDT 2010


Hi all,
I'm trying to install TinyOs on Ubuntu 9.10 karmic
I've followed the wiki:
http://docs.tinyos.net/index.php/Installing_TinyOS_2.1.1#Two-step_install_on_your_host_OS_with_Debian_packages
but I still have problem related to classpath

This is what I did:
deb http://tinyos.stanford.edu/tinyos/dists/ubuntu karmic main
added to /etc/apt/sources.list

update and upgrade by apt

TinyOS-2.1.1 (2.1.1-20100401) installed by:
# apt-get install tinyos-2.1.1

source /opt/tinyos-2.1.1/tinyos.sh
added to / ~/.bashrc

when I run tos-check-env I get following warning:

# tos-check-env

Path:

	/usr/local/sbin

	/usr/local/bin

	/usr/sbin

	/usr/bin

	/sbin

	/bin

	/usr/games



Classpath:

	

	/opt/tinyos-2.1.1/support/sdk/java



--> WARNING: CLASSPATH may not include
/opt/tinyos-2.1.1/support/sdk/java/tinyos.jar. Please ensure that
/opt/tinyos-2.1.1/support/sdk/java/tinyos.jar is in your CLASSPATH or
you may experience configuration problems

--> WARNING: CLASSPATH may not include '.' (that is,  the symbol for
the current working directory). Please add '.' to your CLASSPATH or
you may experience configuration problems.





rpms:





nesc:

	/usr/bin/nescc

	Version: nescc: 1.3.1





perl:

	/usr/bin/perl

	Version: v5.10.0 built for i486-linux-gnu-thread-multi



flex:



bison:



java:

	/usr/bin/java



--> WARNING: The JAVA version found first by tos-check-env may not be
version 1.4 or version 1.5one of which is required by TOS. Please
ensure that the located Java version is 1.4 or 1.5



graphviz:

	/usr/bin/dot

	dot - Graphviz version 2.20.2 (Wed Sep 16 11:12:11 UTC 2009)



--> WARNING: The graphviz (dot) version found by tos-check-env is not
1.10. Please update your graphviz version if you'd like to use the
nescdoc documentation generator.





tos-check-env completed with errors:



--> WARNING: CLASSPATH may not include
/opt/tinyos-2.1.1/support/sdk/java/tinyos.jar. Please ensure that
/opt/tinyos-2.1.1/support/sdk/java/tinyos.jar is in your CLASSPATH or
you may experience configuration problems

--> WARNING: CLASSPATH may not include '.' (that is,  the symbol for
the current working directory). Please add '.' to your CLASSPATH or
you may experience configuration problems.

--> WARNING: The JAVA version found first by tos-check-env may not be
version 1.4 or version 1.5one of which is required by TOS. Please
ensure that the located Java version is 1.4 or 1.5

--> WARNING: The graphviz (dot) version found by tos-check-env is not
1.10. Please update your graphviz version if you'd like to use the
nescdoc documentation generator.



Could you help me please?

Many thanks

Davide


More information about the Tinyos-help mailing list