[Tinyos-help] Make "[program] Error 57" on uisp command

McArthur, Christian cm1481 at txstate.edu
Mon Apr 19 14:52:30 PDT 2010


Howdy All!

I'm experiencing an odd problem when running 'make' to compile and upload code to a mote.  I had no issues with this several months ago and can't figure out what has changed in the time I walked away from the project.  First some information on the environment, then the error.

I'm running TinyOS 2.1 under Cygwin and Windows XP.  I am using a MicaZ mote from Crossbow (MPR2400CA).   I connect the mote to the computer via USB cable and at that point COM3 and COM4 appear for the mote.  The command line I am using for the make process is:

make micaz install mib520,/dev/ttyS2

The error is occurring whether I attempt this for the tutorial program Oscilloscope, code I've written based upon Oscilloscope, and even the Blink application.

As for the error, here are the last two lines of the make process (if you want to see it all, I can provide it):

uisp -dprog=mib510 -dserial=/dev/ttyS2 --wr_fuse_h=0xd9 -dpart=ATmega128  --wr_fuse_e=ff   --erase --upload if=build/micaz/main.srec.out-10 --verify
make: *** [program] Error 57

The only reference to Error 57 I've found is in the sys/errno.h file which says it is due to "Bad font file fmt" and one reference to it on this mailing list in the past, but no suggestion on a resolution or if the poster's problem was ever solved.  

I've tried several sets of code (as mentioned above) and tried referencing the com port differently (/dev/ttyS2, /dev/ttyS3, COM3, COM4).  Anyone have suggestions on what the problem could be or other things to check on?

Thanks,
--Christian


More information about the Tinyos-help mailing list