[Tinyos-help] Error in DIP protocol

arthi p arthi_pk at yahoo.co.in
Mon Apr 26 07:41:08 PDT 2010


Hi all, 
 
I tried to run DIP protocol in TOSSIM and motelab. My apps folder contained EasyDisseminationAppc.nc, EasyDisseminationC.nc,makefile, datainject.java files.
When I tried to give the cmd "java DipInject 0a 2 "ab cd ef" am getting the following error.
 
$ java DipInject 0a 2 "ab cd ef"
Usage: java DipInject [key] [version] [hex data delimit space in quotes]
Key: 10
Version: 2
Data: 171 205 239
getenv JNI library not found. Env.getenv will not work
(run the tos-install-jni tool, see man tos-install-jni for more details)
sf at localhost:9002 died - exiting (java.net.ConnectException: Connection re
 connect)
 
while testing in motelab i do not know to upload which class file..also i am getting the following error in motelab.
 
DBLOGGER ERROR: dbDump: could not extract AMTYPE from message class. Exiting.
java.lang.NoSuchFieldException: AM_TYPE
at java.lang.Class.getField(Class.java:1520)
at dbDump.parseClasses(dbDump.java:213)
at dbDump.main(dbDump.java:736)
  
Please help me out.. Can you tell me how to run the DIP in tossim and also in motelab.
 
Thanks and Regards,
Arthi

-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20100426/7782d353/attachment-0001.htm 


More information about the Tinyos-help mailing list