[Tinyos-help] Make "[program] Error 57" on uisp command

McArthur, Christian cm1481 at txstate.edu
Thu Apr 29 17:54:08 PDT 2010


I have not yet had a chance to try to read the fuses on the mote.  This evening I did discover that everyone in the lab is having the same problem.  We are using separate workstations, though we do have similar setups in terms of OS and software versions.  The problem is occurring with multiple motes as well.  So it's interesting the same error is happening with across all workstations and motes.  

I do have two motes that I have the BaseStation and sense code running on from a few months ago.  They work just fine; the sensing mote does it's thing and radios out the readings, the baseStation receives them and reports them to the computer.  The problem only occurs when running make to install new code to the mote and happens immediately following the uisp command.

I may attempt at installing one of the VMWare Player packages on the TinyOS site and see if it will work that way, but if I can avoid those complications it would be nice.

--Christian
________________________________________
From: mgm ncm [mgm.ncm at gmail.com]
Sent: Friday, April 23, 2010 1:42 AM
To: McArthur, Christian
Cc: tinyos-help
Subject: Re: [Tinyos-help] Make "[program] Error 57" on uisp command

Hi,

I am not sure about the exact solution,but you can try to read the fuses of the MicaZ,so that u can make sure that the communication channel is good.

On Tue, Apr 20, 2010 at 3:22 AM, McArthur, Christian <cm1481 at txstate.edu<mailto:cm1481 at txstate.edu>> wrote:
Howdy All!

I'm experiencing an odd problem when running 'make' to compile and upload code to a mote.  I had no issues with this several months ago and can't figure out what has changed in the time I walked away from the project.  First some information on the environment, then the error.

I'm running TinyOS 2.1 under Cygwin and Windows XP.  I am using a MicaZ mote from Crossbow (MPR2400CA).   I connect the mote to the computer via USB cable and at that point COM3 and COM4 appear for the mote.  The command line I am using for the make process is:

make micaz install mib520,/dev/ttyS2

The error is occurring whether I attempt this for the tutorial program Oscilloscope, code I've written based upon Oscilloscope, and even the Blink application.

As for the error, here are the last two lines of the make process (if you want to see it all, I can provide it):

uisp -dprog=mib510 -dserial=/dev/ttyS2 --wr_fuse_h=0xd9 -dpart=ATmega128  --wr_fuse_e=ff   --erase --upload if=build/micaz/main.srec.out-10 --verify
make: *** [program] Error 57

The only reference to Error 57 I've found is in the sys/errno.h file which says it is due to "Bad font file fmt" and one reference to it on this mailing list in the past, but no suggestion on a resolution or if the poster's problem was ever solved.

I've tried several sets of code (as mentioned above) and tried referencing the com port differently (/dev/ttyS2, /dev/ttyS3, COM3, COM4).  Anyone have suggestions on what the problem could be or other things to check on?

Thanks,
--Christian
_______________________________________________
Tinyos-help mailing list
Tinyos-help at millennium.berkeley.edu<mailto:Tinyos-help at millennium.berkeley.edu>
https://www.millennium.berkeley.edu/cgi-bin/mailman/listinfo/tinyos-help




More information about the Tinyos-help mailing list