[Tinyos-help] nesc1 error imote2 platform

Javier Ortiz orcaja at hotmail.com
Fri Aug 3 09:13:47 PDT 2012


hi!I tried to install the imote2 platform following the steps onhttp://docs.tinyos.net/tinywiki/index.php/Imote2however, when I test it typing:cd $TOSROOT/apps/Blink
make intelmote2I got the following
nesc1: invocation of arm-none-eabi-gcc to find builtin macros failed (error message output follows)
Using built-in specs.
Target: arm-none-eabi
Configured with: ../gcc-4.3.3/configure --target=arm-none-eabi --prefix=/usr/arm/none-eabi --enable-interwork --enable-multilib --enable-languages=c --with-newlib --disable-shared --with-headers=../newlib-1.17.0/newlib/libc/include
Thread model: single
gcc version 4.3.3 (GCC) 
COLLECT_GCC_OPTIONS='-v' '-E' '-dM' '-mtune=iwmmxt' '-march=iwmmxt'
 /usr/arm/none-eabi/libexec/gcc/arm-none-eabi/4.3.3/cc1 -E -quiet -v -D__USES_INITFINI__ /dev/null -mtune=iwmmxt -march=iwmmxt -dM
/usr/arm/none-eabi/libexec/gcc/arm-none-eabi/4.3.3/cc1: error while loading shared libraries: libmpfr.so.1: cannot open shared object file: No such file or directory
nesc1: internal error: couldn't define builtin macros - exiting
I tried to find the library libmpfr.so.1 with sudo find / -name "libmpfr.*" and I got this:
/usr/lib/libmpfr.so
/usr/lib/libmpfr.la
/usr/lib/libmpfr.a
/usr/lib/libmpfr.so.4
/usr/lib/libmpfr.so.4.0.0
Now I don't know what else should I do.any advice is very welcome.thanks in advance.joc 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20120803/2dae86ea/attachment.htm 


More information about the Tinyos-help mailing list