[Tinyos-help] Zolertia Z1 GPIO pull-up

Antonio Linan alinan at zolertia.com
Tue Aug 14 13:45:41 PDT 2012


I'm not sure, those are weak resistors, I normally avoid using the internal
ones and use regular 10K for most sensors.

Regards,

--Antonio

On Tue, Aug 14, 2012 at 10:26 PM, Gašper Černevšek <gapipro at gmail.com>wrote:

> Well I checked out trunk again and tried test. It worked this time, then I
> realized it was my mistake because I was calling function .makeOutput()
> before .setResistor().
>
> Is it normal that output is only 320mV? Is there any way to make it higher?
>
>
> 2012/8/14 Antonio Lignan <alinan at zolertia.com>
>
>> Have you tried the example at /apps/tests/z1/TestGPIO ? See the README
>> and post back the serial output result if it fails.
>>
>> How are you checking if work/fails?
>>
>> BR
>>
>> --Antonio
>>
>>
>> Gašper Černevšek <gapipro at gmail.com> wrote:
>>
>> Hi,
>>
>> has anyone managed to get pull-up working on SouthPort JP1C? Sample tests
>> that come with tinyos are not working.
>>
>> --
>> LP,
>> Gašper
>>
>
>
>
> --
> LP,
> Gašper
>



-- 
--
Antonio Liñan Colina
R+D+I Engineer
@: alinan at advancare.com
@: alinan at zolertia.com
------------------------------
Advancare
T: +34 93 582 02 70
http://www.advancare.com
http://www.zolertia.com
http://zolertia.sourceforge.net
http://webshop.zolertia.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20120814/7c5d7f81/attachment.htm 


More information about the Tinyos-help mailing list