[Tinyos-help] msp430-46 unable to install

Michiel Konstapel m.konstapel at sownet.nl
Mon Apr 7 08:04:22 PDT 2014


Quick followup question, since Eric let me know that the tinyprod repo is indeed offline - where does one conveniently get a fresh TinyOS/MSP430 toolchain from at the moment? Build from source? TinyOS build instructions at http://tinyos.stanford.edu/tinyos-wiki/index.php/Installing_From_Source look easy enough but I'm not sure about building mspgcc and I'd very much prefer one of the pre-built LTS versions.
Cheers,
Michiel

From: tinyos-help-bounces at millennium.berkeley.edu [mailto:tinyos-help-bounces at millennium.berkeley.edu] On Behalf Of Michiel Konstapel
Sent: Thursday, March 27, 2014 17:37
To: tinyos-help at millennium.berkeley.edu
Subject: Re: [Tinyos-help] msp430-46 unable to install

Is the TinyProd repository still broken? I just tried to install on a new machine (Ubuntu Server 13.10, 64 bit), which failed. In /etc/apt/sources.list, I have:

deb http://tinyprod.net/repos/debian squeeze main
deb http://tinyprod.net/repos/debian msp430-46 main

Attempting to install:

$ sudo apt-get install msp430-46
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
msp430-46 : Depends: msp430-binutils-46 but it is not installable
             Depends: msp430-gcc-46 but it is not installable
             Depends: msp430-libc-46 but it is not going to be installed
             Depends: msp430mcu-46 but it is not going to be installed
             Depends: msp430-gdb-46 but it is not installable
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install msp430-binutils-46
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  gcc-4.8-base:i386 libc6:i386 libgcc1:i386
Suggested packages:
  glibc-doc:i386 locales:i386
The following NEW packages will be installed:
  gcc-4.8-base:i386 libc6:i386 libgcc1:i386 msp430-binutils-46:i386
0 upgraded, 4 newly installed, 0 to remove and 5 not upgraded.
Need to get 27.9 MB/32.0 MB of archives.
After this operation, 9821 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
  msp430-binutils-46
Install these packages without verification [y/N]? y
Get:1 http://tinyprod.net/repos/debian/ msp430-46/main msp430-binutils-46 i386 2.21.1-LTS20120406 [27.9 MB]
Fetched 1 B in 6s (0 B/s)
Failed to fetch http://tinyprod.net/repos/debian/pool/main/m/msp430-binutils-46/msp430-binutils-46_2.21.1-LTS20120406_i386.deb  Size mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

If this repo is offline, what's the current alternative?

Thanks,
Michiel

From: tinyos-help-bounces at millennium.berkeley.edu<mailto:tinyos-help-bounces at millennium.berkeley.edu> [mailto:tinyos-help-bounces at millennium.berkeley.edu] On Behalf Of Antonio Linan
Sent: Tuesday, February 25, 2014 12:03
To: Vandana Bhasin
Cc: tinyos-help at millennium.berkeley.edu<mailto:tinyos-help at millennium.berkeley.edu>
Subject: Re: [Tinyos-help] msp430-46 unable to install

See:
http://tinyprod.net/debian-dev/README-46.html
--Antonio

On Tue, Feb 25, 2014 at 11:54 AM, Vandana Bhasin <vandana.bhasin at yahoo.com<mailto:vandana.bhasin at yahoo.com>> wrote:
Hello,

I am unable to install the msp430-gdb-46 package. A similar error message pops up for other msp packages

apt-get install msp430-gdb-46
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package msp430-gdb-46

Following instructions on github, unable to connect for keys also

root at ubuntu:~# gpg --keyserver keyserver.ubuntu.com<http://keyserver.ubuntu.com> --recv-keys 34EC655A
gpg: WARNING: unsafe ownership on configuration file `/home/vandanabhasin/.gnupg/gpg.conf'
gpg: external program calls are disabled due to unsafe options file permissions
gpg: keyserver communications error: general error
gpg: keyserver receive failed: general error

Can anybody please help resolve this issue?


Thanks

Vandana

_______________________________________________
Tinyos-help mailing list
Tinyos-help at millennium.berkeley.edu<mailto:Tinyos-help at millennium.berkeley.edu>
https://www.millennium.berkeley.edu/cgi-bin/mailman/listinfo/tinyos-help



--
--
Antonio Liñán Colina
R+D Engineer
@: alinan at advancare.com<mailto:alinan at advancare.com>
@: alinan at zolertia.com<mailto:alinan at zolertia.com>
------------------------------
Advancare
Ph.: +34 935 511 403
http://www.advancare.com<http://www.advancare.com/>
http://www.zolertia.com<http://www.zolertia.com/>
http://zolertia.sourceforge.net
http://webshop.zolertia.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://www.millennium.berkeley.edu/pipermail/tinyos-help/attachments/20140407/5d7001de/attachment-0001.htm 


More information about the Tinyos-help mailing list